Updaterad Debian 8: 8.5 utgiven

4 juni 2016

Debianprojektet presenterar stolt den femte uppdateringen av sin stabila distribution Debian 8 (med kodnamn jessie).. Denna uppdatering lägger huvudsakligen till rättningar till säkerhetsproblem till den stabila utgåvan, tillsammans med några korrigeringar för allvarliga problem. Säkerhetsbulletiner har redan publicerats separat och refereras när dom finns tillgängliga.

Vänligen notera att denna uppdatering inte innebär en ny version av Debian 8 utan endast uppdaterar några av de inkluderade paketen. Det finns ingen anledning att kasta bort gamla jessie-CDs eller DVD-skivor utan allt som behövs är att uppdatera via en uppdaterad Debianspegling efter en installation, för att få alla inaktuella paket uppdaterade.

Dom som frekvent installerar uppdateringar från security.debian.org kommer inte att behöva uppdatera många paket och de flesta uppdateringar från security.debian.org inkluderas i denna uppdatering.

Ny installationsmedia och CD- och DVD-avbildningar med uppdaterade paket kommer snart att finnas tillgängliga på dom vanliga platserna.

En uppgradering online till denna revision görs vanligtvis genom att peka paketverktyget aptitude (eller apt) (se manualsidan för sources.list(5)) mot en av Debians många FTP eller HTTP-speglingar. En fullständig lista över speglingar finns tillgänglig på:

https://www.debian.org/mirror/list

Blandade felrättningar

Denna uppdatering av den stabila utgåvan lägger till några viktiga following packages:

Paket Orsak
autofs Remove stray debugging output in log files
bareos Fix GnuTLS backend initialization, TLS negotiation for passive filedaemons
base-files Update for the point release
chrony Fix CVE-2016-1567: Restrict authentication of server/peer to specified key; remove /var/lib/chrony on purge only; rework postrotate log rotation script
clamav New upstream release
cyrus-imapd-2.4 Drop broken caldav support
debian-edu Add libdns-mdns to tasks/desktop-other and tasks/main-server to make CUPS browsing really functional; add avahi-discover, mdns-scan, avahi-autoipd and kdnssd to tasks/main-server as suggested packages
debian-edu-config Backport various bug fixes
debian-edu-doc Update wheezy and jessie documentation
debian-edu-install Update version number to 8+edu0
debian-installer Rebuild against proposed-updates; add sata-modules for arm64 - some machines do have SATA CD
debian-installer-netboot-images Rebuild against new debian-installer; swap the d-i Built-Using with the installer fetching, to fail on version mismatches earlier
dpkg Add more Conflicts for removed packages expecting dpkg to ship install-info; remove trailing space before handling blank line dot-separator in Dpkg::Control::HashCore. Regression introduced in dpkg 1.17.25; only use the SHELL environment variable for interactive shells; move tar option --no-recursion before -T in dpkg-deb; initialize Config-Version also for packages previously in triggers-pending state; fix memory leak in dpkg infodb format upgrade logic; fix physical file offset comparison in dpkg; add kfreebsd-armhf support to ostable and triplettable; add NIOS2 support to cputable
evince Fix crashes when document has pages removed and is reloaded, and when a recent document fails to load
ext4magic Fix an issue which makes impossible to recover or examine Ext4 filesystems
fusionforge Disable mediawiki plugin, as mediawiki is being removed
gitolite3 Enable repository paths without '~/' in git-annex-shell
glusterfs Add missing glusterd hook script to glusterfs-server package
gosa Several bugfixes
gpa Fix check of dialog return values
groovy Fix remote execution of untrusted code and possible DoS vulnerability [CVE-2015-3253]
hexchat Verify hostnames when ssl is in use
hivex Fix ruby-hivex installation
icedove Fix build failure on mips; fix build on arm{el,hf}
icedtea-web New upstream release, fixes CVE-2015-5235 and CVE-2015-5234
initramfs-tools Include drivers/nvme in block driver modules; create ORDER files even if there are no valid scripts
libcrypto++ Fix Rijndael timing attack counter measure [CVE-2016-3995]
libdatetime-timezone-perl Update to tzdata 2016d
libksba Do not abort on decoder stack overflow [CVE-2016-4353]; fix integer overflow in the BER decoder (CVE-2016-4354 CVE-2016-4355), encoding of invalid utf-8 strings in dn.c [CVE-2016-4356], OOB read access in _ksba_dn_to_str, possible read access beyond the buffer [CVE-2016-4579]
libreoffice Fix build failure on ppc64el due to changes in OpenJDK; fix logic to not install sound files
linux Revert some changes in 3.16.7-ckt25-1 which caused issues on some systems with Radeon graphics cards and when inserting a USB device
lvm2 Set default pid directory to /run
mathematica-fonts Update for new upstream file version (10); only TrueType fonts are now available; add missing dependency on wget
nam Build-Depend on tcl / tk >= 8.6
ngspice Run lyx with a temporary -userdir to not rely on $HOME
nlpsolver Add missing Depends: on libreoffice-java-common
nmap Fix versioned breaks/replaces; deal with unuseable socks proxy; ignore unenumerable interfaces; move ndiff.py from zenmap to ndiff
opam Fix insecure certificate handling
openjdk-7 Fix build failure on arm{el,hf}
openssl Update expired certificates used by test suite; update to 1.0.1t stable release; use alternate trust chains; use correct digest when exporting keying material; security fixes [CVE-2015-3197 CVE-2015-1793]
pepperflashplugin-nonfree Update Google public key; remove 32 bit support
perl Apply selected bug-fix patches taken from 5.20.3; fix debugperl crashes with XS modules; CVE-2015-8853 fix regexp engine hang on illegal UTF8 input; fix UTF8-related regexp engine crash
postgresql-9.1 New upstream release
postgresql-9.4 New upstream release
quota Change invocation of quota services, so systemd takes over most of the work
redmine Load all database drivers for all Redmine instances
tklib Fixed typo in Plotchart version which prevented its loading
tzdata New upstream release
wmforecast Update for new Yahoo! weather API
xapian-core Fix possible database corruption, especially with recoll
xarchiver Fix crash when attempting to cancel extract here in Thunar plugin
xscreensaver Remove warning about outdated version
zendframework Fix regression from ZF2015-08: binary data corruption; fix ZF2016-01: Potential Insufficient Entropy Vulnerability in ZF1

Säkerhetsuppdateringar

Denna revision lägger till följande säkerhetsuppdateringar till den stabila utgåvan. Säkerhetsgruppen har redan givit ut bulletiner för var och en av dessa uppdateringar

Bulletin-ID Paket
DSA-3410 icedove-l10n
DSA-3410 iceowl-l10n
DSA-3410 enigmail
DSA-3410 icedove
DSA-3432 icedove
DSA-3473 nginx
DSA-3476 postgresql-9.4
DSA-3482 libreoffice
DSA-3485 didiwiki
DSA-3491 icedove
DSA-3495 xymon
DSA-3520 icedove
DSA-3530 tomcat6
DSA-3533 openvswitch
DSA-3535 kamailio
DSA-3537 imlib2
DSA-3538 libebml
DSA-3539 srtp
DSA-3540 lhasa
DSA-3542 mercurial
DSA-3543 oar
DSA-3544 python-django
DSA-3545 cgit
DSA-3546 optipng
DSA-3549 chromium-browser
DSA-3550 openssh
DSA-3552 tomcat7
DSA-3554 xen
DSA-3555 imlib2
DSA-3556 libgd2
DSA-3557 mysql-5.5
DSA-3558 openjdk-7
DSA-3559 iceweasel
DSA-3560 php5
DSA-3561 subversion
DSA-3562 tardiff
DSA-3563 poppler
DSA-3564 chromium-browser
DSA-3565 pdns
DSA-3565 ovito
DSA-3565 botan1.10
DSA-3565 softhsm
DSA-3565 qtcreator
DSA-3566 openssl
DSA-3567 libpam-sshauth
DSA-3568 libtasn1-6
DSA-3569 openafs
DSA-3570 mercurial
DSA-3571 ikiwiki
DSA-3572 websvn
DSA-3573 qemu
DSA-3574 libarchive
DSA-3575 libxstream-java
DSA-3576 icedove
DSA-3577 jansson
DSA-3578 libidn
DSA-3579 xerces-c
DSA-3580 imagemagick
DSA-3581 libndp
DSA-3582 expat
DSA-3583 swift-plugin-s3
DSA-3584 librsvg
DSA-3585 wireshark
DSA-3586 atheme-services
DSA-3587 libgd2

Borttagna paket

Följande paket har tagits bort på grund av omständigheter utom vår kontroll:

Paket Orsak
lyz Beroende på zotero-standalone-build som är på väg att tas bort
mediawiki Får ej säkerhetsstöd längre
mediawiki-math Beroende på mediawiki som är på väg att tas bort
zotero-standalone-build Oanvändbar i jessie

Borttagningen av mediawiki gör att metapaketet "fusionforge-full" inte kan installeras i jessie. Detta problem uppmärksammades tyvärr inte i tid för att rättas med punktutgåvan, men kommer att lösas via jessie-updates snart.

Debianinstalleraren

Installeraren har uppdaterats för att inkludera rättningarna som har into inkluderats i den stabila stabila utgåvan med denna punktutgåva.

URLer

Den fullständiga listan på paket som har förändrats med denna revision:

http://ftp.debian.org/debian/dists/jessie/ChangeLog

Den nuvarande stabila utgåvan:

http://ftp.debian.org/debian/dists/stable/

Föreslagna uppdateringar till den stabila utgåvan:

http://ftp.debian.org/debian/dists/proposed-updates

Information om den stabila stabila utgåvan (versionsfakta, kända problem, osv.):

https://www.debian.org/releases/stable/

Säkerhetsbulletiner och information:

https://security.debian.org/

Om Debian

Debianprojektet är en grupp utvecklare av Fri mjukvara som donerar sin tid och kraft för att producera det helt fria operativsystemet Debian.

Kontaktinformation

För mer information, besök Debians webbplats på https://www.debian.org/, skicka e-post till <press@debian.org>, eller kontakta gruppen för stabila utgåvor på <debian-release@lists.debian.org>.